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The Badge Tutorial (Pics) Updated: 9/14

Badge Tutorial
Note: This is in response to the seven requests I have received while playi
the HW2 demo as to how I got my custom badge in the game. Hopefully th
will be good enough for a sticky and all I'll have to do in the future is tell
people to head to the Relic Forums.

*** Update 9/14 Save yourself some aggravation. This tool, though orignia
used for Descent III, will work in HW2. Just save a single frame. Thanks to
Uberjumper.

Wolf359 got it to work with the GIMP.

*** Update 9/08 Malignus got it to work with PSP 7.02. Steps on how afte
Photoshop Tutorial.

*** Update 9/07 Since this got the sticky, I'll update my post with new ba
tips and tutorials for other programs. If you know how to make a transpare
badge with PaintShop, GIMP or some other program, write it up as clearly
and coherently as possible and PM it to me or post it. I'll try it if I have
program, and if I can get it to work I'll post it, giving you credit of course,
the original post.

Programs still needed:
- Descent III Logo Maker thingie
(open to other suggestions)

Welcome to the badge tutorial for HW2. Making a badge is a very simple
process. Having done it once, you will be able to churn them out like some
similie I can't even imagine. For those of you who do not have PS7, I will d
a quick generic run-down of what properties a badge must have. Hopefully
you can figure it out with whatever program you use.

Image must be 64x64 pixels.

Image must be either a 24 or 32bit Targa (.tga).

To use transparency, image must have an alpha channel and be 32b

Image must not be compressed.

In the alpha channel, Black is transparent and White is opaque - any
value in between is partially transparent.
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This assumes you have an image you want to import into HW2 as a badge
show how to make part of it transparent; if you don't want transparency, d
step 1 and then skip to the saving out steps.
Photoshop 7

Step 1
Open the file.

Step 2
Erase the parts that you want to be transparent. You want to make sure th
the checkered background is showing in these areas.

Step 3
In the menu bar, select Image->Image Size..

Make sure 'Constrain Proportions' is unclicked, then change the two boxes
under 'Pixel Dimensions' to 64. Click ok.

Step 4
All that's left is to save out the image in the proper format. To do this, go t
the menu bar. File-> Save As..

Save the file as a Targa (.tga) with 32bits/pixel resolution, in the folder
C:\Program Files\Sierra\Homeworld2 Demo\Bin\Profiles\Badges\

===============================================

PaintShop Pro
Thanks directed at Malignus

Doing this in PSP 7.02 is a cinch.

Step 1
Make your image and select the part of it you want to be transparent using
the magic wand. Then use Selections > Modify > Expand a couple of pixels
make sure you get all of the empty space, then hit Selections > Invert.

Step 2
You should now have selected everything solid (i.e. non-transparent) that
want to include. Click Selections > Save to Alpha Channel.

Step 3
Resize the image to 64 by 64 pixels. Then save the image as a 24-bit,
uncompressed TGA.

(Supplementary Info)
From the PSP 7 help on adding an alpha channel:

Use the Save to Alpha dialog box to save a selection to an alpha channel. T
open the dialog box, choose Selections > Save To Alpha Channel. This
command is available only when the image contains a selection.

Using the Save to Alpha Dialog Box
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Step 1
When the dialog box opens, the filename of the image appears in the
Available Documents box, and the selection is displayed in the Preview box

Step 2
In the Available Alpha list, double-click New Channel, or highlight New
Channel and click OK. The New Channel dialog box opens.

Step 3
Type a name for the new selection.

Step 4
Click OK. Paint Shop Pro saves the selection to the alpha channel and close
both dialog boxes.

===============================================

The GIMP
Thanks to Wolf359

A) Get the GIMP.

B) Find some image you want to use, in my case I used logos I could find
from old/defunct sports franchises.

C) Now preferably you have an image with a white or otherwise constant
background, I'll assume you want to take that out, and leave yourself with
just the central image to work with.

D) Drop the image into the GIMP, you'll see the GIMP menu with the head
File, Xtns, Help and so on. The image will be in a seperate window, first th
to do is to right click on the image, scroll down to select, and chose the by
color... option. This will open another window which will probably have a
completely black image displayed. Move the cursor over the white (or the
background, whatever color it is) to select that color. This will highlight on
that portion of the image that has the color you clicked upon. If this is the
color you want to delete, continue on. If not try again until you've selected
what you want to erase.

E) Now, close the select by color window and return to the image, right cli
on the image and scroll down to the Layers menu, chose the add alpha
channel option, this will prime your selected background colors for remova

F) Once you've added the alpha channel, right click on the image again and
scroll down to edit-clear. This should have the effect of deleting the
background color, allowing you to see the checkerboard (transparent)
background behind your image. Now select the "select rectangular regions"
tool from the GIMP menu and click on your image, this will take the selecti
off.

G) In my case I had some trouble getting my images to face the right
direction when applied as a badge, to fix this its necessary to rotate and fl
the image. To rotate your image, right click on the image and scroll down t
the Image menu, then to Transforms, then to Rotate, and finally select 180
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flip the image on its head. Now to flip on the horizontal plain, (usually
necessary to avoid a "mirror" image) right click on your image scroll down
Tools, Transform Tools and flip, this will change your cursor to a horizontal
line with two arrows at either end, left click anywhere on your image and
move the mouse to the right, this will flip the image horizontally for you.

H) Now since HW2 chokes on indexed color images, (and yours might be
one), right click on the image and scroll down to the image menu, scroll to
the mode option and you'll see several options RGB, Grayscale and Indexe
you want your image to be RGB, so if the option is available select it, if it i
not, go to the View menu and select Image Info, if it reports your image is
RGB image of at least 24 bits, your fine. This is important to remember yo
image needs to be 24/32 bits and RGB for it to work as a badge.

I) Now that the image is ready, we can shrink it down, apply some blurring
you wish) and apply some transparency.

J) To shrink the image right click and bring up the menu, scroll down to th
Image menu and select the Scale image option. In the upper part of the
menu you will see several text boxes, below the first set labeled New Widt
and Height are two other boxes called Ratio X, and Y. To the right of those
boxes is a small chain link, click this link and see that the chain is broken,
will allow you to select any size and not have the CPU keep the aspect ratio
the same. Now in the New Width and Height boxes type in 64 for both. On
your done close the window to the Scale menu.

K) Now it helped me to blur my image some before shrinking it, when you
the bluring does not matter much but bluring will help make sure your bad
doesn't have sharp jagged edges. To blur what I did was I right clicked on
the image, scrolled down to the Filters menu, selected the blur menu and
selected the Selective Gaussian Blur option. I usually leave the settings alo
and apply the blur, this component is optional.

L) Once your image is down to badge size, it helps to add some transparen
so the image wont completely cover up the markings on the Mothership or
ship its applied to, this adds to realism. First right click, and scroll to the
Layers menu, select Layers, Channels and Paths option. This will open a ne
window, all you really need to do here is click the Keep Trans. Box first, th
you'll notice the Opacity slider, edit this slider to the desired level, I usuall
set it to 80. Once your done close the Layers Channels and Paths menu.

M) Now its time to save, right click your image and scroll to file, save as. W
the menu open select the path you want your file to be saved in, also be s
to chose the TGA extension in the Save Options area, where it says
Determine File Type, this will change your image name to image.tga, you'r
nearly done, when you hit save, the program will give you an option to Ex
your image, if you do NOT get this option, your image is probably not in RG
format, and you need to try again. The box will say something about needi
to merge visible layers, go ahead and export, then another menu will come
with two radio boxes and two options labeled RLE Compression and Origin
Bottom Left, I usually unclick both and hit ok.

Now you have a badge ready to go, probably not the most simple thing in
world but it works. The two most important things that will agrivate you in
this process that you should avoid is 1) remember to make your image an
RGB image, indexed color wont work, and 2) be sure to unclick the chain
relating to ratio size when resizing your image, you don't want to end up w
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a 69x64 or 64x67 image that looks right but wont work. Anyway I do hope
this helps anyone needing to create a badge in the GIMP, good luck.

The next time you fire up HW2 and use the profile maker, you should see a
new badge. If you see a weird error message or the background is messed
up, you forgot to follow one of the steps above. Try again.

Contributors:
Shooter (Hosting)
Malignus (Paintshop)
Wolf359 (The GIMP)

__________________
If you've read the books, you know how a "starfish" relates to space. If no
then indulge your imagination with the amusing scenario of an ocean-dwel
invertebrate twitching in the void.

Last edited by Starfisher on 09-15-2003 at 03:32 AM

09-04-2003 10:53 PM

slimpinto
Member

Registered: Mar 2003
Clan:

Sitcky this please!

__________________
SAY REALLY FAST!

When beetles battle beetles in a puddle paddle battle and the beetle
battle puddle is a puddle in a bottle...

...They call this a tweetle beetle bottle puddle paddle battle muddle!

09-04-2003 10:58 PM

Shooter
Member

Registered: Jul 2002
Clan:

I'll host them.

Why? I'm a nice guy. And I settle down rather quickly.

So I'm back to my normal generous self now.

Talk to me on IRC

---------
[edit]I'll try to recreate this for fireworks is needed.

[edit] Fireworks 4 doesn't save stuff as a TGA.

__________________
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Mike Chance on #homeworld

Last edited by Shooter on 09-05-2003 at 06:07 PM

09-04-2003 11:08 PM

MajorFreak
MajorGeek

Registered: Apr 2003
Clan: syncronized lockage
swimmers

hot damn! you rule!

09-04-2003 11:36 PM

Sebas_V
Member

Registered: Sep 2003
Clan:

any chance somebody do this with PSP7 ?

__________________
Grtz Sebas

09-04-2003 11:38 PM

JamesX
Member

Registered: Nov 2002
Clan: Kushan

Not sure, but I don't think you need the additional alpha layer. When
you save as tga I think photoshop automatically calcualtes the alpha
based on your transparencies. I haven't made my logo yet, so I can't
say this is 100% true.

09-04-2003 11:51 PM
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MajorFreak
MajorGeek

Registered: Apr 2003
Clan: syncronized lockage
swimmers

quote:

Originally posted by JamesX
Not sure, but I don't think you need the additional alpha layer.
When you save as tga I think photoshop automatically
calcualtes the alpha based on your transparencies. I haven't
made my logo yet, so I can't say this is 100% true.

if true, i wonder why the assumption? How about other programs?

09-05-2003 12:16 AM

Larkaan
Member

Registered: Jul 2003
Clan: 9th

great, thanks much Starfisher. I second the nomination for sticky-
ness.

Already made mine, gonna have to try it... hope it works.

__________________
This is my signature. *scribble* Can't read it? I can't either...

Formerly Thrawn[9th] and Thrawn[IX]

09-05-2003 12:19 AM

MajorFreak
MajorGeek

Registered: Apr 2003
Clan: syncronized lockage
swimmers

http://forums.relicnews.com/showthr...2015#post212015
that link goes to my current index for tutorials...no picture though in
other threads, that's why this one rules. (even though PS is
overqualified)

still goto figure out this whole "alpha channels" thing for specific
programs

09-05-2003 12:39 AM
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Yakuza
Member

Registered: Sep 2003
Clan:

ok, well I was messing around with creating logos before i saw this
thread, and since people seem so into creating logos I thought I'd
post a few up in here, if you guys want them.

I'll just post that one for now, here's the link to download it.

If you guys want more I'll put those up too.

Oh, you guys should also know that its possible to have multi-colored
logos along with retaining some 3D effects...for example :

That currently works perfectly well, but because of the angle of it
looks a little strange on the ships. But it does retain all the colors and
dimension.

EDIT : Seems as if Lycos.UK doesn't like me posting hw2logos or
some such, because they seem to have completely closed and deleted
my account for no reason in the last hour. So once I find more
hosting services I'll post more..

Last edited by Yakuza on 09-05-2003 at 02:58 AM

09-05-2003 01:25 AM

Vijil
The Dom

Registered: May 2002
Clan: Anar Rinde

you dont actually need the alpha channel stuff, photoshop
automatically does this to the transparencies. I tried it. As long as ps
says its transparent, hw2 will too.

09-05-2003 01:35 AM

zbobet2012
Member

Registered: Dec 2002
Clan: I aint i your family

How do you alpha channel in psp8?

09-05-2003 02:48 AM
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Gyokuran
Member

Registered: Dec 2002
Clan: Ministry of Kek

Uh... isnt the layer mask another name for alpha channel in
photoshop? You can just go to "add layermask" and paint in black
what you want transparent. I'd think that would be alot easier, and it
worked on the partly transparent badge I did.

09-05-2003 03:38 AM

Antra
Member

Registered: Aug 2003
Clan:

I use Fireworks, and it seems pretty easy .

09-05-2003 04:22 AM

JamesX
Member

Registered: Nov 2002
Clan: Kushan

This is redundently complicated. I just tried it. Photoshop
automatically sets the alpha layer for you. My Logo (Thunder Cats)
worked perfectly. There is no need to add another alpha layer, just
make sure you set it as 32 bit, and don't compress RLE.

here is the example, in brower they might not show up well, but it
shows up in the Profile selection perfectly

Hiigaran (Thunder Cats)

Vaygr (Chinese Dragon)

Last edited by JamesX on 09-05-2003 at 07:07 AM

09-05-2003 06:26 AM

All times are GMT +3 hours. The time now is 01:59 PM.   
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