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Introduction

Flash is the industry standard for interactive vector 
graphics and animation for the Web.

As you work in Flash, you create a movie by 
drawing or importing artwork, arranging it on the 
Stage, and animating it with the Timeline.

You make the movie interactive by using actions to 
make the movie respond to events in specified ways.
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What’s new in Flash MX

It makes some significant productivity and 
performance enhancements whatever you are doing 
traditional animations, rich Internet applications, 
delivering video online or developing for mobile 
phones and devices.

It integrates rich media and interactivity.

Some featuring innovations like ActionScript
programming, database connectivity capabilities 
and re-usable components.
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Working Environment

Each time you open Flash, the application creates a 
new file, with the FLA extension. 

In each FLA file, there is a stage for you create your 
movie.

First of all, you should set the size, frame rate, 
background color, and other properties of a new 
movie in the Movie Properties dialog box be 
choosing Modify > Document.
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Working Environment

For Frame Rate, enter the number of animation 
frames to be displayed every second. For most 
computer-displayed animations, especially those 
playing from a Web site, 8 fps (frames per second) 
to 12 fps is sufficient. (12 fps is the default frame 
rate.)
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Working Environment

To specify the Stage size in pixels, enter values for 
Width and Height. 

To set the Stage size so that there is equal space 
around the content on all sides, click Match 
Contents. To set the Stage size to the maximum 
available print area, click Match Printer.

To set the background color of your movie, choose 
a color from the Background color swatch.
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The Stage and the Timeline

Like films, Flash movies divide lengths of time into 
frames. The Stage is where you compose the 
content for individual frames in the movie, drawing 
artwork on it directly or arranging imported 
artwork. 

The Timeline is where you coordinate the timing of 
the animation and assemble the artwork on 
separate layers. The Timeline displays each frame in 
the movie. 
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Symbols and instances

Symbols are reusable elements that you use with a 
movie. Symbols can be graphics, buttons, movie 
clips, sound files, or fonts.

When you place a symbol on the Stage, you create 
an instance of that symbol. 

Layers act like stacked sheets of transparent acetate, 
keeping artwork separate so you can combine 
different elements into a cohesive visual image. 
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Creating animation overview

You create animation by changing the content of 
successive frames. There are two methods for 
creating an animation sequence in Flash: frame-by-
frame animation and tweened animation.

In frame-by-frame animation you create the image 
in every frame.

In tweened animation, you create starting and 
ending frames and let Flash create the frames in 
between. 
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Shape Tweening

Shape tweening means the transformation of the 
shape of the object.

Flash cannot tween the shape of groups, symbols, 
text blocks, or bitmap images. Use Modify > Break 
Apart to apply shape tweening to these elements. 

To tween a shape:

1. Click a layer name to make it the current layer and 
select an empty keyframe where you want the 
animation to start. 
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Shape Tweening

2. Insert a keyframe and create the image for the first 
frame of the sequence. 

3. Insert a keyframe and create the image for the last 
frame of the sequence. 

4. Select any frame in-between the first and the last 
frames, choose Window > Panels > Frame.

5. For Tweening, select Shape.
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Shape Tweening

To break apart groups or objects:

1 Select a group, text block, bitmap, or symbol that you 
want to break apart.

2 Choose Modify > Break Apart

Breaking apart complex symbols and large blocks of 
text can take a long time. You might need to increase 
the application's memory allocation to properly break 
apart complex objects.
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Motion Tweening

In motion tweening, you define properties such as 
position, size, and rotation for an instance, group, or 
text block at one point in time, and then you change 
those properties at another point in time.

In a motion tweening, the object must be grouped in 
advance.

To make a motion tweening

1. Click a layer name to make it the current layer, and 
select an empty keyframe in the layer where you want 
the animation to start. 
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Motion Tweening

2. Insert a keyframe and create the image for the first 
frame of the sequence. 

3. Insert a keyframe and locate the final position of the 
image for the last frame of the sequence.

4. Select any frame in-between the first and the last 
frames, choose Window > Panels > Frame.

5. For Tweening, select Motion.
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Motion Tweening

To group the objects:

1 Select those objects you want to group.

2 Choose Modify > Group

To ungroup the objects:

1 Select those objects you want to group.

2 Choose Modify > Ungroup
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Using Layers

Layers are like transparent sheets of acetate stacked 
on top of each other. 

When you create a new Flash movie, it contains one 
layer. You can add more layers to organize the 
artwork, animation, and other elements in your 
movie. 

You can hide layers, lock layers, or display layer 
contents as outlines. You can also change the order 
of layers. 
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Using Layers

To create a layer, do one of the following:

- Click the Add Layer button at the bottom of the 
Timeline, or, 

- Choose Insert > Layer.

To delete a layer, do one of the following:

- Select the corresponding layer and click the 
rubbish bin button.
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Using Scenes

Scene is the stage where you work. Besides layers, 
you can also add several scenes in your movie.

To add scene, do one of the following:

Choose Insert > Scene.

To delete scene, do one of the following:

Choose Insert > Remove Scene



Web-based Learning - by KS Chan 19

Using Scenes

To switch from one scene to another:

Click the Edit Scene button

If there is not specified, the movie always starts at 
scene 1.
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Creating button

Buttons are actually four-frame interactive movie 
clips. When you select the button behavior for a 
symbol, Flash creates a Timeline with four frames.

The first three frames display the button's three 
possible states; the fourth frame defines the active 
area of the button. 

The Timeline doesn't actually play; it simply reacts 
to pointer movement and actions by jumping to the 
appropriate frame. 
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Creating button

To create a button: 

1. Draw a symbol in a frame

2. Group the symbol

Select the symbol > Choose Modify > Group

3. Convert the symbol into button

Select the grouped symbol > Choose Insert > 
Convert to symbol > Choose button in the dialog 
box.
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Creating button

4. Double click the button

5. Edit the four states of the button
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Creating button

6. Select the Down frame and insert a keyframe to it. 

It is the state of the button when the mouse is held 
down. The subject must be ungroup  before editing.
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Creating button

7. Select the Over frame and insert a keyframe to it. 
It is the state of the button when the mouse is 
placed over it.

8. Select the Hit frame and insert a keyframe to it. 
It defines the effective area of the button.
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Action Script

Script can be added to the movie to make it 
interactive.

To add an action script, select a frame > right click > 
Action
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Action Script

Stop

To stop the movie.

Go To

To goto and play a specified scene and frame.

GetURL

To a specified URL.
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Flash – Action Script
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Basic Action

Get URL – Opens specified URL in optionally stated window.

on (release) {
getUrl(http://www.yahoo.com, _self);

}

Go To – Go to a specified line number or label and either play or 
stop.

gotoAndPlay(7);
gotoAndStop(“Score”);
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Basic Action

If Frame Is Loaded – Determines whether a specified frame is 
loaded. The action is often used in early frames as a preloader.

ifFrameLoaded (“Scene 1”, 14) {
gotoAndPlay(4);

}

Load Movie – Loads a specified movie at a URL in a stated level or 
into a specified target movie clip.

on (release) {
loadMovie(“Movie1.swf”, 1)

}
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Basic Action

On Mouse Event – Triggers a script when the mouse or keyboard 
event occurs.

on (release) {
unLoadMovie (44);

}

Mouse event includes : on (release), on (press), on (releaseOutside), 
on (rollOver), on (rollOut), on (dragOver), on (dragOut).

on (keyPress”B”) {
unLoadMovie (44);

}
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Basic Action

Play – Plays movie. No parameters.

play ( );

Stop – Stops movie. No parameters.

stop ( );

Stop All Sounds – All sounds are turned off.

stopAllSounds ( );



Web-based Learning - by KS Chan 32

Actions
Break – Stops a repeated action in a loop.

do {
k = k + 1;
if (k > 6) {

break;
}

} while (k < 9);

Call – Initiates an action in a specified frame but does not open the 
frame.

call (“4”);

Comment – Allows remarks in a script without any action taken.

// This is a remark
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Actions
do while – Loop until the termination condition is met.

do {
k = k + 1;

} while (k < 9);

If…then…else – Provides a conditional structure.

if (k = 8) {
gotoAndPlay (1);

} else {
gotoAndPlay(10);

}

for – Loop from an initial set value to a termination condition at an
increment level.

for (k = 1; k < 10; k++) {
box = k;

}
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Actions
OnClipEvent – Action script associated with the selected movie 
clip.

onClipEvent (load) {
score = 1;

} 

Clip event includes : onClipEvent (enterFrame), onClipEvent (unload), 
onClipEvent (mouseDown), onClipEvent (mouseUp), onClipEvent
(mouseMove), onClipEvent (keyDown), onClipEvent (keyUp), 
onClipEvent (data)

Print – Sends a specified bounding box in the named level or 
target to a printer as a vector graphic.

print (0, “Movie1”);
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Functions
ord – Returns the ASCII encoding value of a character.

k = ord(“a”);

getProperty – Returns the value of the specified property of the 
specified target.

k = getProperty(InstanceName, _x);

getTimer – Returns the number of millisecond since the started 
playing.

t = getTimer( );
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Functions
int – Returns a value with the decimal value truncated.

k = 34.964;
n = int(k);

number – Converts an expression to a floating point or Boolean 
number. 

k = “145.67”;
a = Number(k);

random – Generates a random number between “0” and “n-1”.

k = random(9);
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Functions
string – Converts a number into a string variable.

k = 34.964;
temp = string(k);

chr – Returns the corresponding character of an ASCII 
value.

CH = chr(65);
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Functions
substring – Returns the partial string defined by (“stringName”, 
index, length).

temp = substring(“SandLight”, 4, 5);

length – Returns the length of the string.

k = length(“SandLight”);
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Properties
_alpha – Level of transparency of an instance.

setProperty(InstanceName, _alpha, 50);

_focusrect – Sets a property to have a yellow rectangle around 
buttons when a tab is used to navigate. 

setProperty(InstanceName, _focusrect, true);

_rotation – A rotation quality has values between 0 and 360. 

setProperty(InstanceName, _rotation, 270);
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Properties
_visible – Set the visibility of the instance.

setProperty(InstanceName, _visible, false);

_width / _height – Set the width/height of the movie clip. 

setProperty(InstanceName, _width, 50);

_x / _y – Set the horizontal/vertical position of a specified movie 
clip. 

setProperty(InstanceName, _x, 0);
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Properties
_xmouse / _ymouse – Returns the horizontal/vertical position of 
the center of the mouse cursor.

xpos = _xmouse;

_totalframes – Returns the total number of frames in a movie clip. 

total = _totalframe;

_framesloaded – Returns the total number of frames in a movie 
clip that has been loaded. 

s = _framesloaded;
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More about 
Flash Action Script
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Introduction

Macromedia Flash provides an easy way to add 
action script to our animation or HTML design.

In Flash animation, action script can be added to 
every frame or every instance on the scene.

Here, we will demonstrate how to create a 
multiple choice interaction using Flash action 
manager.
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Getting Start

We will start with creating the Start-up page of the whole 
multiple choice action. The layout is as follow:
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Creating the Start-up Page
1. Start a new page

i. Select File>New to start a new page for the movie.

ii. Select Modify>Document to set the dimension of 
the page and the background color of the page.
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Creating the Start-up Page
2. Add a text to the start-up page

Select TEXT TOOL from the tool bar, place the text 
cursor on the page and type “Computer Quiz”

In the Properties box, you can set the size and color 
of the text.
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Creating the Start-up Page
3. Add a button to the start-up page

Select TEXT TOOL from the tool bar, place the text 
cursor on the page and type “Click here to Start”

In the Properties box, you can set the size and color 
of the text

Select ARROW TOOL from the tool bar, click on the 
text to select it
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Creating the Start-up Page

iv. Select Insert>Convert to Symbol to concert the 
text to a button

v. In the Symbol Properties dialog, use the default 
name for the symbol, set the symbol behavior to 
Button and click OK

Note : If the button is made up of a graphic and a text, you 
should first group them together before conversion.
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Creating the Start-up Page
4. Change the appearance of the button

i. Select ARROW TOOL from the tool bar, double click 
on the button to edit its appearance. Make sure that 
the frames on the timeline is changed to UP, OVER, 
DOWN and HIT

ii. Select the frame OVER. Right click the mouse and 
select Insert keyframe
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Creating the Start-up Page

iii. Select TEXT TOOL from the tool bar, highlight the 
text and change its color when mouse over

iv. Select the frame DOWN. Right click the mouse and 
select Insert keyframe

v. Select TEXT TOOL from the tool bar, highlight the 
text and change its color when mouse down
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Creating the Start-up Page

vi. Select the frame HIT. Right click the mouse and 
select Insert keyframe

vii. Select RECTANGLE TOOL from the tool bar. Place 
a rectangle on the text “Click here to Start” to 
define the hit area of the button. 

Note : The hit area is an invisible area where the finger 
cursor appears when the mouse arrow cursor is 
place over it 
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Creating the Start-up Page
5. Return to Scene1

After changing the appearance of the button, click 
the Scene1 button above the timeline to return to 
scene1
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Creating the Start-up Page
6. Adding action script to the button

Select ARROW TOOL from the tool bar and click on 
the button to select it. Make sure the Action box is at 
Action - Button
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Creating the Start-up Page

ii. An Object Actions dialog box appears on the 
screen. The Mouse Event action script is added by 
automatically.

iii. Set the mouse event to Release as default.
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Creating the Start-up Page
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Creating the Start-up Page

iv. Double click Go To action script under 
Actions>Movie Control. 

v. Set Scene to <Current Scene>, Type to Frame 
Number, Frame to 2 and check the Go to and Stop 
box. 

vi. Close the dialog
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Creating the Start-up Page
7. Adding action script to the frame

i. Select ARROW TOOL from the tool bar and click on 
the 1st frame of the timeline to select it. Right click on 
the button and select Actions. A Frame Actions 
dialog appears on the screen.

ii. We will then add a variable to the interaction to store 
the total mark of the student in the quiz. Double click 
var action script under Actions. 
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Creating the Start-up Page

vi. In the variable field, type Mark = 0

vii. Close the dialog 
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Creating the First Question Page

We will create a new page for the first question. 
The layout is as follow:
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Creating the First Question Page
1. Create a new frame for the first question

i. Select the 2nd frame on the timeline of Scene 1. 
Right click on the frame and select Insert blank 
keyframe. 
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Creating the First Question Page
2. Insert the first question

i. Select RECTANGLE TOOL from the tool bar, draw a 
unfilled rectangle on the page to hold the question text.

ii. Select TEXT TOOL from the tool bar. Place the text 
cursor inside the rectangle and type the question title 
“Which of the following is NOT an input device?”

Note : You can edit the style and size of the text in the 
Properties Box.
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Creating the First Question Page
3. Insert Choice A

i. Select RECTANGLE TOOL from the tool bar, draw a 
unfilled rectangle with rounded corner on the page to 
hold Choice A.

ii. Select TEXT TOOL from the tool bar. Place the text 
cursor inside the rectangle and type the answer for the 
choice “A. Keyboard”
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Creating the First Question Page
4. Convert Choice A to button

i. Select both the rectangle and the text of choice A. 
Group the two elements together by selecting 
Modify>Group

ii. Select the grouped object, select Insert>Convert to 
Symbol to change the object to button

iii. In the Symbol Properties dialog, use the default name 
for the symbol, set the symbol behavior to Button and 
click OK
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Creating the First Question Page
5. Change the appearance of the button

i. Double click on the button to edit its appearance. Make 
sure that the frames on the timeline is changed to UP, 
OVER, DOWN and HIT

ii. Change the Over and Down appearance of the button 
and define the HIT area. (Refer to p.49 to p.51 for the 
procedures) 
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Creating the First Question Page
6. Insert Choice B

i. Return to Frame 2 of Scene 1, draw the Choice B 
button on the stage using RECTANGLE TOOL and 
TEXT TOOL. Type “B. Monitor” for the text of the 
button

ii. Follow the same procedures of Choice A, group the 
two elements and convert the grouped object to 
symbol. Change the appearance of the button as well.

Note : Choice B is the correct answer
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Creating the First Question Page
7. Display the mark on the stage

i. Select TEXT TOOL from the toolbar, place the text 
cursor at the right button corner of the stage and type 
“Point : ”

ii. Place another text cursor next to “Point : ”, it is a 
dynamic text field to hold the mark of the quiz.

iii. Leave the content of the text box empty. 
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Creating the First Question Page

iv. In the Properties box, select Dynamic Text and the 
Single Line option. Type TOTAL in the Var field as 
the variable name of the text in the text box.
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Creating the First Question Page
8. Add action script to the frame

i. Select the 2nd frame of the timeline. Right click on the 
frame and select Actions

ii. In the Frame Actions dialog box, double click Stop
under Actions>Movie Control

iii. We will then display the mark on the text field TOTAL 
of the frame. Double click = action script under 
Operators>Assignment
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Creating the First Question Page

iv. In the expression field, type TOTAL = Mark 

v. Close the dialog box
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i. Select the Choice A, make sure the Actions box 
shows Actions - Button

Ii Double click Go To action script under 
Actions>Movie Control. 

iii. Set Scene to <Current Scene>, Type to Frame 
Number, Frame to 3 and check the Go to and Stop 
box. Frame 3 contains question 2 of the quiz

Creating the First Question Page
9. Add action script to the Choice A
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i. Select the Choice C, right click on the button and 
select Actions

ii. An Object Actions dialog box appears on the 
screen. Add the same script under the On Mouse 
Release event as that of Choice A.

iii. Repeat the same procedures for Choice D.

Creating the First Question Page
10. Add action script to the Choice C and Choice D
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i. Select the Choice B, right click on the button and 
select Actions

ii. Double Click = under Operators>Assignment. In 
the expression field, type Mark = Mark + 10

iii. Double Click Go to under Actions>Movie Control. 
Set  scene to <Current Scene>, Type to Frame 
Number, Frame to 3 and check the Go to and Stop 
box. 

Creating the First Question Page
11. Add action script to the Choice B
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Creating the First Question Page

vi. Close the dialog box
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Creating the Second Question Page

To create the second question page, click on the 
3rd frame of the timeline and insert a keyframe on it. 
The rest is done in the same way as before.
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