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Introduction

Macromedia CourseBuilder is an extension 
application to Dreamweaver for creating Web-
based learning content and interactive Web pages.

It extends Dreamweaver with a set of easy to use 
templates and tools that simplify and accelerate the 
development of online learning content.

Learning interactions created with CourseBuilder
are 100% Web-native, enabling cross-platform and 
cross-browser delivery without plug-ins or applets.
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What you can do with CourseBuilder

CourseBuilder helps you quickly design compelling 
learning interactions with step-by-step assistance. 
In minutes, you can:

1. Create true/false, multiple-choice, and all-that-
apply quizzes

2. Create drag-and-drop matching exercises

3. Create explore interactions

4. Create text-entry interactions

5. Create buttons, timers, and sliders
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Using CourseBuilder – Hot Area

1. Before you start, create a new folder in your local 
computer for hosting all files and resources in your 
site.

i. Open File Manager

ii. Create a new folder MySite under C:/

iii. Copy the whole folder from

C:\ProgramFiles\Macromedia\Dreamweaver MX 
2004\CourseBuilder\Tutorial\cb_tutorial

to

c:\Mysite
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Using CourseBuilder – Hot Area

2. Define a Local Site under Dreamweaver

i. Launch CourseBuilder for Dreamweaver. A blank 
document opens

ii. Choose Site > New Site

iii. In the Site Definition dialog box, make sure Local Info is 
selected in the Category list

iv. In the Site Name field, type Test.

v. Click the folder icon to the right of the Local Root Folder 
field, navigate to the MySites\cb_tutorial folder
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Using CourseBuilder – Hot Area

vi. Click OK

vii. Click Create when asked if you’d like to create a cache file 
for the site

viii. Leave the Site window open
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Using CourseBuilder – Hot Area

3. Create an explore CourseBuilder Interaction

i. Choose File > Open

ii. In the dialog box, navigate to Sites/cb_tutorial/

cb_discover, then select cb_explore.htm, and click 
Select to open the file.
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Using CourseBuilder – Hot Area

4. Copy support files

i. Choose Modify > CourseBuilder > Copy Support File

ii. Click OK to create the necessary folders and to copy the 
files. The files are copied to the cb_discover folder.
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Using CourseBuilder – Hot Area

5. Insert a CourseBuilder Interaction

i. In the Document window, click in the middle of the 
document to place the insertion point after existing page 
elements.

ii. In the Object palette’s Common panel, click the 
CourseBuilder Interaction icon to open the 
CourseBuilder Interaction dialog box.
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Using CourseBuilder – Hot Area

6. Select the type of interaction

i. In the CourseBuilder Interaction dialog box, under Target, 
4.0+ Browsers should already be selected. If it is not, 
select it

ii. Select Explore in the Category list

iii. Click the icon for the Explore_Areas template
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Using CourseBuilder – Hot Area

7. Add graphics for the hot areas

i. Start by clicking the Hot Areas tab

ii. In the Hot Areas list, Hot Area1 is already selected. In the 
Image field, click Browse. Then, in the Select 
Appearance dialog box, navigate to the cb_graphics
folder and select toy_racer.gif. Then click Select.



Web-based Learning - by KS Chan

Using CourseBuilder – Hot Area

8. Add three more hot area graphics

i. In the Hot Areas list, select HotArea2.

ii. In the Image field, click Browse. Then, in the Select 
Appearance dialog box, navigate to the cb_graphics folder 
and select toy_coldfusion.gif. Then click Select.

iii. In the Hot Areas list, select HotArea3.

iv. In the Image field, click Browse. Then, in the Select 
Appearance dialog box, navigate to the cb_graphics folder 
and select toy_satellite.gif. Then click Select.

v. In the Hot Areas list, select HotArea4.
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Using CourseBuilder – Hot Area

vi. In the Image field, click Browse. Then in the Select 
Appearance dialog box, navigate to the cb_graphics folder 
and select toy_waverider.gif. Then click Select.

vii. Click OK to close the CourseBuilder Interaction dialog box.

viii. Save your file.
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Using CourseBuilder – Hot Area

9. Arrange the hot areas in the document

i. In the Document window, select the text “Click on a hot 
area” at the top of the screen, then press Backspace to 
delete it.

ii. In the Document window, click the border of a hot area 
layer to select the layer. Handles appear around a selected 
layer. Click the layer tab, on the upper left corner, then 
drag the layer where you want to position it.

iii. Save your changes.
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Using CourseBuilder – Hot Area

10. Add a layer for user feedback

i. Click the Layer icon on the Object palette.

ii. Move the pointer to the Document window, then drag to 
draw a layer in the right side of the document.

iii. Click the border of the layer to select it. Then, in the 
Property inspector’s LayerID field, replace the default text 
“Layer1” by typing ProductInfo.
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Using CourseBuilder – Hot Area

iv. In the Document window, click in the middle of the 
ProductInfo layer to set the insertion point in the layer.

v. In the Object palette, click the Image icon to insert an 
image in the layer. The Select Image Source dialog box 
appears.

iv. In the dialog box, navigate to the cb_graphics folder, select 
text_any.jpg, and click Select to insert the image in the 
layer. In the properties box, name the image as TOY.



Web-based Learning - by KS Chan

Using CourseBuilder – Hot Area

11. Editing a CourseBuilder Interaction

i. Click the CourseBuilder Interaction icon in the 
Document window.

ii. Click any of the hot area layers, then click <interaction>
in the tag selector. 

iii. In the Property inspector, click Edit to open the 
CourseBuilder Interaction dialog box.
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Using CourseBuilder – Hot Area

12. Add a swap image action for racer product 
information

i. Start by clicking the Action Manager tab.

ii. In the Action Manager list under “if Hot Area1 
Selected,” select Popup Message, then click Cut.

iii. Select “if Hot Area1 Selected,” then in the Actions pop-
up menu choose Swap Image, and click Add.
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Using CourseBuilder – Hot Area

i. In the Swap Image dialog box, “unnamed <img>” is 
selected. This is the image you inserted in the ProductInfo
layer. You’ll swap this image for an image that describes 
the image in Hot Area 1, the racer. 

ii. In the “Set Source to” field, click Browse.

iii. In the Select Image Source dialog box that appears, select 
text_racer.jpg, then click Select to display the image.

iv. Click OK to close the dialog box.
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Using CourseBuilder – Hot Area

13. Add a swap image action for Cold Fusion product 
information

i. In the Action Manager list under “if Hot Area2 
Selected,” select Popup Message, then click Cut.

ii. Select “if Hot Area2 Selected,” then in the Actions pop-
up menu choose Swap Image, and click Add.

iii. In the “Set Source to” field, click Browse.

iv. In the Select Image Source dialog box, select 
text_coldfusion.jpg, then click Select to display the 
image.

v. Click OK to close the dialog box.
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Using CourseBuilder – Hot Area

14. Add a swap image action for satellite product 
information

i. In the Action Manager list under “if Hot Area3 
Selected,” select Popup Message, then click Cut.

ii. Select “if Hot Area3 Selected,” then in the Actions pop-
up menu choose Swap Image, and click Add.

iii. In the Select Image Source dialog box, select 
text_satellite.jpg, then click Select to display the image.

iv. Click OK to close the dialog box.
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Using CourseBuilder – Hot Area

15. Add a swap image action for wave-rider product 
information

i. In the Action Manager list under “if Hot Area4 
Selected,” select Popup Message, then click Cut.

ii. Select “if Hot Area4 Selected,” then in the Actions pop-
up menu choose Swap Image, and click Add. 

iii. In the Select Image Source dialog box, select 
text_waverider.jpg, then click Select to display the 
image.

iv. Click OK to close the dialog box.

v. Click OK to close the CourseBuilder Interaction dialog box.
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Using CourseBuilder – Hot Area

16. Create a link to the next page

i. In the Object palette’s Common panel, click the Layer 
icon, then move the pointer to the page, and drag to draw 
a layer in the space beneath the ProductInfo layer.

ii. Click the layer to select it, then move the layer if you need 
to position it. Use the layer tab on the upper left corner of 
the layer to position the layer.

iii. Click in the layer to place the insertion point in the layer. In
the Object palette, click the Image icon to insert an 
image in the layer.
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Using CourseBuilder – Hot Area

iv. In the Select Image Source dialog box, open the 
cb_graphics folder (if it’s not already open), select 
Arrow_Sharp_Right.gif, and click Select.

v. In the Property inspector, click the folder icon next to the 
Link field. Then, in the Select File dialog box, navigate to 
the cb_discover folder, select cb_drag_drop.htm, and 
click Select to select the file to open when the arrow is 
clicked.

vi. Click the border of the layer to select it, then use one of 
the handles to resize the layer to the size of the graphic.

vii. Save your document.
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Using CourseBuilder – Hot Area

17. Test the explore interaction

i. Choose File > Preview in Browser, and choose the 
browser you want to use. The browser launches and 
displays the page.

ii. Click each of the products and make sure the correct 
information appears.

iii. Click the arrow to see if it goes to the “Know your target 
audience” page.
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Using CourseBuilder – Drag&Drop Interaction

1. Insert a CourseBuilder Interaction

i. Choose File > Open. In the dialog box that appears, 
navigate to cb_drag_drop.htm, and click Select to open 
the file.

ii. If the Object palette isn’t already open, choose Window > 
Objects to open it.

iii. In the Document window, click in the middle of the 
document to place the insertion point after existing page 
elements.

iv. In the Object palette’s Common panel, click the 
CourseBuilder Interaction icon. The CourseBuilder
Interaction dialog box appears.
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Using CourseBuilder – Drag&Drop Interaction

2. Select the type of interaction

i. In the CourseBuilder Interaction dialog box, under Target, 
select 4.0+ Browsers if it isn’t already selected.

ii. Select Drag and Drop in the Category list.

iii. Click the icon for the many-to-many matching 
template.
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Using CourseBuilder – Drag&Drop Interaction

3. Define the General tab options

i. Click the General tab.

ii. Under Judge Interaction, select “when the user drops a 
drag element.” This option causes feedback to display 
every time the user moves a toy image to a target 
audience image—rather than waiting until the user has 
tried to match every toy with a target audience.

iii. Under Reset, accept the default setting “Create a Reset 
button for this Interaction.”
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Using CourseBuilder – Drag&Drop Interaction

iv. Under Reaction, select “Snap back if incorrect.” This 
returns the toy to its original position if the user drags it to
the wrong target audience.

v. Under Reaction, accept the default setting “Snap back if 
not dropped on target.” This returns the toy to its 
original position if the user drags it somewhere other than 
a target area.

vi. Under Layer, select “Insert this Interaction in a layer”
to place the question text in a layer, making it easy for you 
to position the text in the document. (Each of the drag-
and-drop images is already in an individual layer.)
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Using CourseBuilder – Drag&Drop Interaction

4. Add drag images

i. Click the Elements tab. Drag1 is already selected in the 
Elements list.

ii. In the Name field, type satellite.

iii. Click the Browse button next to the Image File box. In the 
cb_graphics folder, select toy_satellite_mini.gif, then 
click Select to display the image for this drag object.

iv. In the Elements list, select Drag2; then in the Name field, 
type waverider.
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Using CourseBuilder – Drag&Drop Interaction

i. Click the Browse button. In the cb_graphics folder, select 
toy_waverider_mini.gif, then click Select to display the 
image for this drag object.

ii. In the Elements list, select Drag3; then in the Name field, 
type racer.

iii. Click the Browse button. In the cb_graphics folder, select 
toy_racer_mini.gif, then click Select to display the image 
for this drag object.
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Using CourseBuilder – Drag&Drop Interaction

5. Add target images

i. In the Elements list, select Target1; then in the Name field, 
type satellitematch.

ii. Click the Browse button. In the cb_graphics folder, select 
kids_climbing.jpg, then click Select.

iii. In the Elements list, select Target2; then in the Name field, 
type waveridermatch.

iv. Click the Browse button. In the cb_graphics folder, select 
kids_bike.jpg, then click Select.
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Using CourseBuilder – Drag&Drop Interaction

v. In the Elements list, select Target3; then in the Name field, 
type racermatch.

vi. Click the Browse button. In the cb_graphics folder, select 
kids_soccer.jpg, then click Select.

vii. Click OK to close the CourseBuilder Interaction dialog box.
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Using CourseBuilder – Drag&Drop Interaction

6. Position the images in the document

i. In the Document window, select a layer by clicking its 
border.

ii. Use the layer tab to drag the layers in your document to 
match this screen layout.

iii. In the Document window, use the pointer to select the 
default text “Drag the objects on the left to the 
correct targets on the right, then press the ‘Submit’
button to check the answer.” Replace the text by 
typing Ready to sell? Drag each toy to its target 
customer.
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Using CourseBuilder – Drag&Drop Interaction

7. Set snap to settings

i. Click one of the images in the drag-and-drop interaction, 
then click <interaction> in the tag selector, and click
Edit in the Property inspector.

ii. Click the Pairs tab.

iii. Select the “satellite:satellitematch” pair if it isn’t 
already selected.
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Using CourseBuilder – Drag&Drop Interaction

iv. Under Snap To, select “pixels down,” and in the pixel 
down field type 70. Then “select pixels to right of the 
target element’s upper left corner,” and in this field 
type 30.

v. When a match occurs, the drag element will move to these 
precise positions in the target element.

vii. Select the “waverider:waveridermatch” pair.

viii. Under Snap To, select “pixels down,” and in the “pixels 
down” field type 70. Then select “pixels to the right of 
the target element’s upper left corner,” and in this 
field type 30.
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Using CourseBuilder – Drag&Drop Interaction

ix. Select the “racer:racermatch” pair.

x. Under Snap To, select “pixels down,” and in the “pixels 
down” field type 70. Then select “pixels to the right of 
the target element’s upper left corner,” and in this 
field type 30.
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Using CourseBuilder – Drag&Drop Interaction

8. Set feedback for a correct response

i. Click the Action Manager tab.

ii. Select the Popup Message action under “if Correct,” and 
click Edit. The Popup Message dialog box appears.

iii. In the dialog box’s Message field, change the default text, 
“Correct,” by typing You’re ready to sell!

iv. Click OK to close the dialog box.
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Using CourseBuilder – Drag&Drop Interaction

9. Delete default feedback for an incorrect or unknown 
response

i. Select “else if Incorrect,” and click Cut.

ii. Select “else if Unknown Response,” and click Cut.

The conditions and their associated Popup Message actions 
are automatically cut.
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Using CourseBuilder – Drag&Drop Interaction

10. Add correct match feedback
i. In the Action Manager list, select the Popup Message action 

below “if Correct,” choose Else from the Actions pop-up 
menu, and click Add. Else is added to the Action Manager 
list.

ii. With “-- else” selected, choose Popup Message in the 
Actions pop-up menu, and click Add. The Popup Message 
dialog box appears.

iii. In the Message field, type That’s right!.

iv. Click OK to close the dialog box.

v. Click OK to close the CourseBuilder Interaction dialog box.

vi. Choose File > Save to save your document.
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Using CourseBuilder – Drag&Drop Interaction

11. Create a link to the next interaction

i. In the Object palette, click the Layer icon, then move the 
pointer to the Document window, and drag the pointer to 
draw a layer in the lower right area of the document.

ii. Select the layer, then position it using the layer tab to 
position the layer.

iii. Click in the layer. In the Object palette, click the Image 
icon to insert an image in the layer.
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Using CourseBuilder – Drag&Drop Interaction

iv. In the Select Image Source dialog box, navigate to the 
cb_graphics folder, select Arrow_Sharp_Right.gif, and 
click Select. An arrow appears in the layer.

v. In the Property inspector, click the folder icon next to the 
Link field to select the file to open when the arrow is 
clicked.

vi. In the Select File dialog box, in the cb_discover folder, 
select cb_mc.htm, and click Select.

vii. Click the border of the layer to select it, then use one of 
the layer handles to resize it to fit the graphic.
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Using CourseBuilder – Drag&Drop Interaction

12. Test the drag-and-drop interaction

i. Choose File > Save, then choose File > Preview in 
Browser. The browser launches and displays the page.

ii. Drag the toys to the descriptions.
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Using CourseBuilder – Multiple Choice Quiz

1. Insert a CourseBuilder Interaction
i. Choose File > Open. In the dialog box that appears, 

navigate to the cb_discover folder and then to cb_mc.htm, 
and click Select to open the document.

ii. If the Object palette isn’t already open, choose Window > 
Objects to open it. 

iii. In the Document window, click in the middle of the 
document to place the insertion point after existing page 
elements.

iv. In the Object palette’s Common panel, click the 
CourseBuilder Interaction icon to open the 
CourseBuilder Interaction dialog box.
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Using CourseBuilder – Multiple Choice Quiz

2. Select the type of interaction

i. In the CourseBuilder Interaction dialog box, under Target, 
select 4.0+ Browsers if it isn’t already selected.

ii. Select Multiple Choice in the Category list.

iii. Click the icon for the multiple-choice image radio 
template.
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Using CourseBuilder – Multiple Choice Quiz

3. Define the multiple-choice interaction
i. Click the General tab.

ii. In the Question Text field, delete the default text.

iii. Under Judge Interaction, select “when the user clicks a 
choice,” if it isn’t already selected.

iv. In Correct When, accept the default setting Any Correct 
and None Incorrect.

v. In Tries Are and Time Is, accept the default setting, 
Unlimited.

vi. Verify that the Reset option is not selected.

vii. Select “Insert this in a layer”
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Using CourseBuilder – Multiple Choice Quiz

4. Define the correct choice

i. Click the Choices tab. In the Choices list, choice1 is 
already selected and marked as correct.

ii. Under Choice Options, in the Name field, change the 
default text “choice1” by typing waverider.

iii. Delete the text in the Text field.

iv. In the Image File field, click Browse.

v. In the Select Appearance dialog box, navigate to the 
cb_graphics folder, then select toy_waverider_mini.gif, 
and click Select.
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Using CourseBuilder – Multiple Choice Quiz

5. Define incorrect choices

i. In the Choices list, select choice2. Notice that “Choice Is” is 
marked incorrect.

ii. Under Choice Options, in the Name field, change the 
default text “choice2” by typing coldfusion.

iii. Delete the text in the Text field.

iv. In the Image File field, click Browse. Then, in the Select 
Appearance dialog box, navigate to the cb_graphics folder, 
select toy_coldfusion_mini.gif, and click Select.
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Using CourseBuilder – Multiple Choice Quiz

v. In the Choices list, select choice3.

vi. Under Choice Options, in the Name field, change the 
default text “choice3” by typing racer.

vii. Delete the text in the Text field.

viii. In the Image File field, click Browse. Then, in the Select 
Appearance dialog box, navigate to the cb_graphics folder, 
select toy_racer_mini.gif, and click Select.
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Using CourseBuilder – Multiple Choice Quiz

ix. In the Choices list, select choice4.

x. Under Choice Options, in the Name field, change the 
default text “choice4” by typing satellite.

xi. Delete the text in the Text field.

xii. In the Image File field, click Browse. Then, in the Select 
Appearance dialog box, navigate to the cb_graphics folder, 
select toy_satellite_mini.gif, and click Select.

xiii. Click OK to close the CourseBuilder Interaction dialog box.
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Using CourseBuilder – Multiple Choice Quiz

6. Create a layer for user feedback

i. In the Document window, click the border of the 
interaction layer to select the layer.

ii. Click the layer tab then drag the layer to place the layer in 
a proper position.

iii. In the Object palette, click the Layer icon. Then move the 
pointer to the Document window, and in the area to the 
left of the choices, drag the pointer to draw a layer.

iv. With the layer selected, in the Property inspector’s LayerID
field, replace the default text “Layer1” by typing Feedback.
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Using CourseBuilder – Multiple Choice Quiz

v. In the Document window, click in the Feedback layer to 
position the insertion point in the layer, then in the Object 
palette, click the Image icon to insert an image in the 
layer.

vi. In the Select Image Source dialog box, navigate to the 
cb_graphics folder, and select text_mc_question.jpg, 
and click Select.

vii. With the image selected, in the Property inspector’s Image 
field, name the image feedback.

viii. Move the layer if you need to so it doesn’t overlap the layer 
containing the choices.
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Using CourseBuilder – Multiple Choice Quiz

7. Set up feedback for a correct response

i. Click anywhere in the layer containing the choices. Then, in 
the tag selector click <interaction>, and in the Property 
inspector click Edit to open the CourseBuilder Interaction 
dialog box.

ii. Click the Action Manager tab.

iii. In the Action Manager list under “if Correct,” select 
Popup Message, and click Cut.
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Using CourseBuilder – Multiple Choice Quiz

iv. In the Action Manager list reselect “if Correct,” then 
choose Swap Image from the Actions pop-up menu, and 
click Add. The Swap Image dialog box appears.

v. In the Images list, select “image in the Feedback 
layer,” then click Browse.

vi. In the Select Image Source dialog box, navigate to the 
cb_graphics folder, select text_feedback_correct.jpg, 
and click Select.

vii. Click OK to close the Swap Image dialog box.
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Using CourseBuilder – Multiple Choice Quiz

8. Set up feedback for wrong response

i. In the Action Manager list under “else if Incorrect,”
select Popup Message, then click Cut.

ii. In the Action Manager list re-select “else if Incorrect,”
then choose Swap Image from the Actions pop-up menu, 
and click Add. The Swap Image dialog box appears.

iii. In the Images list, select “image in the Feedback 
layer,” then click Browse.

iv. In the Select Image Source dialog box, navigate to the 
cb_graphics folder, and select 
text_feedback_incorrect.jpg, and click Select.
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Using CourseBuilder – Multiple Choice Quiz

v. Click OK to close the Swap Image dialog box.

vi. Click OK to close the CourseBuilder Interaction dialog box.
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Using CourseBuilder – Multiple Choice Quiz

9. Test the interaction

i. Choose File > Save, then press F12 to preview the page 
in a browser.

ii. When the document opens try the interaction:

Click the first button, and you receive feedback that your 
choice is right.

Click the other three buttons, and you receive feedback 
that your choice is wrong.
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Using CourseBuilder – Multiple Choice Interaction

1. Insert a CourseBuilder Interaction

i. Choose File > Open.

ii. In the Open dialog box, navigate to the cb_discover folder, 
then select the file named cb_nav.htm, and click Open.

iii. If the Object palette isn’t already open, choose Window > 
Objects to open it. 

iv. In the Document window, click in the middle of the 
document to place the insertion point after existing page 
elements.

v. In the Object palette’s Common panel, click the 
CourseBuilder Interaction icon.
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Using CourseBuilder – Multiple Choice Interaction

2. Select the type of interaction

i. In the CourseBuilder Interaction dialog box, under Target, 
select 4.0+ Browsers if it isn’t already selected.

ii. In the Category list, select Multiple Choice. The icons in 
the Gallery represent the multiple-choice CourseBuilder
Interactions that will function in version 4 and later 
browsers.

iii. Click the icon for the graphic multiple-choice image 
radio template.
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Using CourseBuilder – Multiple Choice Interaction

3. Define the multiple-choice interaction

i. Click the General tab.

ii. In the Question Text field, replace the text “Put your 
question text here” by typing:

Here’s the latest on our new line of toys - specs, 
prices, and this quarter’s sales incentives. Explore 
first, then test your knowledge with a couple of 
quizzes.

Click a button to choose:

The text instantly updates in the Document window when 
you click another field on this tab.
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Using CourseBuilder – Multiple Choice Interaction

iii. Under Judge Interaction, accept the default setting, “when 
the user clicks a choice.” This option dictates that the 
interaction is instantly judged when a user makes a 
selection.

iv. In Correct When, accept the default setting, Any Correct 
and None Incorrect.

v. In Tries Are and Time Is, accept the default settings, 
Unlimited. You aren’t limiting the number of tries, nor the 
amount of time the user has to respond correctly to the 
question in this interaction.

vi. Verify that the Reset option is not selected.
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Using CourseBuilder – Multiple Choice Interaction

vii. Select “Insert this Interaction in a layer” to place the 
CourseBuilder Interaction in a layer so you can easily 
position it in the document.



Web-based Learning - by KS Chan

Using CourseBuilder – Multiple Choice Interaction

4. Define the choices

i. Start by clicking the Choices tab. In the Choices list, 
“choice1(correct)” is already selected.

ii. In the Name field, replace the default text “choice1” by 
typing Explore.

iii. In the Text field, replace the default text “Text for choice1”
by typing Explore the new products. This is the text the 
user sees on the screen.

iv. In the Choice Is pop-up menu, select Not Judged. This 
interaction guides navigation, so a user’s choice isn’t 
correct or incorrect.
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Using CourseBuilder – Multiple Choice Interaction

v. In the Choices list, click “choice2” to select it. Notice that 
the Name field changes; it now matches the selected 
choice in the Choices list.

vi. In the Name field, replace the default text “choice2” by 
typing DD.

vii. In the Text field, replace the default text “Text for choice2”
by typing Know your target customer.

viii. In the Choice Is pop-up menu, select Not Judged.
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Using CourseBuilder – Multiple Choice Interaction

ix. In the Choices list, click “choice3” to select it.

x. In the Name field, replace the default text “choice3” by 
typing MC. 

xi. In the Text field, replace the default text “Text for choice3”
by typing What’s in it for you.

xii. In the Choice Is pop-up menu, select Not Judged.

xiii. In the Choices list, select “choice4” then click Delete to 
remove this choice from the interaction.
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Using CourseBuilder – Multiple Choice Interaction

5. Select the Action Manager tab

i. Start by clicking the Action Manager tab.

ii. In the Action Manager list, select Segment:Correctness
to select this segment.

iii. Click Edit. The Segment Editor appears.

iv. In the Segment Name field, replace the default text, by 
typing Navigation.

v. Click OK to close the dialog box.
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Using CourseBuilder – Multiple Choice Interaction

6. Define the explore condition

i. In the Action Manager list, select the “if Correct”
condition.

ii. Click Edit. The Condition Editor appears.

iii. In the Condition Name field, type Explore selected to 
indicate which condition is represented.

iv. In the rightmost Interaction pop-up menu, which currently 
shows <none>, select Button “Explore.”

v. In the bottommost Type pop-up menu, make sure True is 
selected.
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Using CourseBuilder – Multiple Choice Interaction

vi. Click OK to close the dialog box.
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Using CourseBuilder – Multiple Choice Interaction

7. Add a Go To URL action

i. In the Action Manager list, under “if Explore selected,”
select Popup Message.

ii. Click Cut to delete this action from the Action Manager list.

iii. In the Action Manager, select “if Explore selected.”

iv. In the Action Manager pop-up menu, choose Go To URL, 
then click Add. The Go To URL dialog box appears.
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Using CourseBuilder – Multiple Choice Interaction

v. In the URL field, click Browse.

vi. In the dialog box that appears, navigate to the cb_discover
folder, then to cb_explore.htm, and click Select to select 
the file to open when the choice is clicked.

vii. The URL field updates.

viii. Click OK to close the dialog box.
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Using CourseBuilder – Multiple Choice Interaction

8. Define the drag-and-drop condition

i. In the Action Manager list, select the “else if Incorrect”
condition.

ii. Click Edit to open the Condition Editor.

iii. In the Condition Name field, type Drag and Drop 
selected to indicate which condition is represented.

iv. In the rightmost Interaction pop-up menu, select Button 
“DD.”

v. In the bottommost Type pop-up menu, make sure True is 
selected.

vi. Click OK to close the dialog box.
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Using CourseBuilder – Multiple Choice Interaction

9. Add a Go To URL action

i. In the Action Manager list, under “else if Drag and Drop 
selected,” select Popup Message.

ii. Click Cut to delete this action from the Action Manager list.

iii. In the Action Manager, select “else if Drag and Drop 
selected.”

iv. In the Action Manager pop-up menu, choose Go To URL, 
then click Add.
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Using CourseBuilder – Multiple Choice Interaction

v. In the Go To URL dialog box, in the URL field, click 
Browse. Then, in the dialog box that appears, navigate to  
cb_drag_drop.htm in the tutorial folder, and click Select 
to select the file to open when the choice is clicked.

vi. Click OK to close the dialog box.
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Using CourseBuilder – Multiple Choice Interaction

10. Define the multiple-choice condition

i. In the Action Manager list select the “else if Unknown 
Response” condition.

ii. Click Edit to open the Condition Editor.

iii. In the Condition Name field, type Multiple Choice 
selected to indicate which condition is represented.

iv. In the rightmost Interaction pop-up menu, select Button 
“MC.”

v. In the bottommost Type pop-up menu, make sure True is 
selected.

vi. Click OK to close the dialog box.
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Using CourseBuilder – Multiple Choice Interaction

11. Add a Go To URL action

i. In the Action Manager list, under “else if Multiple Choice 
selected,” select Popup Message.

ii. Click Cut to delete this action from the Action Manager list.

iii. In the Action Manager, select “else if Multiple Choice 
selected.”

iv. In the Action Manager pop-up menu, choose Go To URL, 
then click Add.
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v. In the Go To URL dialog box, in the URL field click Browse. 
Then in the dialog box that appears, navigate to 
cb_mc.htm in the cb_discover folder, and click Select to 
select the file to open when the choice is clicked.

vi. Click OK to close the dialog box, then click OK to close the 
CourseBuilder Interaction dialog box.

vii. Choose File > Save to save your document.
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Using CourseBuilder – Multiple Choice Interaction

12. Position the interaction in the document

i. Click the border of the layer to select it.

ii. Then do the following to resize or move the layer:

Use the layer tab (on the upper left corner) to drag the 
layer to the desired location.

Drag any of the layer handles to resize the layer.

iii. Save your changes.
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Using CourseBuilder – Multiple Choice Interaction

13.Test the interaction

i. Choose File > Preview in Browser. Your browser opens 
and displays the interaction.

ii. Click each of the buttons to test your site. The other 
interaction pages you created appear.

iii. Close your browser when you are done testing your site.
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Using CourseBuilder – Text Input

The text entry CourseBuilder Interaction displays a 
single- or multiple-line HTML text input box that  
accepts either plain or password-encrypted text.

Text that the user types in the box is compared 
against characters or strings (called possible 
responses) defined for the CourseBuilder
Interaction.

When user input matches one of the defined 
strings, actions occur—depending on whether you 
have designated the string as correct, incorrect, or 
not judged.
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Using CourseBuilder – Text Input

1. Insert a CourseBuilder Interaction

Insert a CourseBuilder Interaction in the document by 
doing one of the following:

i Click the Insert CourseBuilder Interaction icon in the Object 
palette.

ii Click the Insert CourseBuilder Interaction icon, then drag it 
to the document window.

iii Choose Insert > CourseBuilder Interaction
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Using CourseBuilder – Text Input

2. In the CourseBuilder Interaction dialog box, under 
Target, select 4.0+ Browsers; then in the Category 
list, select Text Entry.

3. In the template gallery, select the text entry icon 
you want to use.
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Using CourseBuilder – Text Input

4. In the General Tag, input the following setting:

i In Judge Interaction, select “when the user clicks a button 

labeled SUBMIT.

ii In Correct When, select “Any Correct and None Incorrect”.

iii Check “Create a Reset Button” and “Insert in a Layer”.



Web-based Learning - by KS Chan

Using CourseBuilder – Text Input

5. In the Response Tag, input the following setting:

i Make sure that Response1 is selected.

ii In Must Contain field, input “wave rider”

iii Uncheck “Case Sensitive” and “Exact Match Required”

iv In Any Other Response Is, select “Incorrect”

v Select Response2 and click Delete

vi Select Response3 and click Delete
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Using CourseBuilder – Text Input

6. Modify the response in Action Manager.

i Under If Correct, select PopUp Message and click Edit

ii In the message box, type “You are Right!!!”

iii Under If Incorrect, select PopUp Message and click Edit

iv In the message box, type “You are Wrong!!!”

v Select Unknown Response and click Delete
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Using CourseBuilder – Text Input

7. Click OK.

8. Replace the placeholder text above the text field 
with a question or instructions.

i Type “Which kind of toy is suitable for kindergarten 

children?”

9. Save the job and press F12 to see the result.
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Class Exercise II

Construct a simple on-line test interface using 
Dreamweaver CourseBuilder. The interface should 
contains two or more pages which are inter-linked. 
You should include at least two of the following 
interactions in the pages:

Hot Area Multiple Choice

Drag and Drop Text Input

Marking Criteria: Authoring skill – 60%

Design and Layout – 20%

User Friendliness – 20%


