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Enhance Your Web Page 
 

Equipment/Software  

In class, we will use Netscape Communicator 4.x running on Windows 98.  If you are completing this class 

on your own, you may substitute for these items as needed. 

 

Handouts & Class Files 

• Class handout:  Enhance Your Web Page 

• How to use File Transfer Protocol 

• Enhance folder on desktop which includes: 

o blueball.gif 

o index.html 

o page2.html 

o redball.gif 

o rollover.txt  

o baileyhall.jpg 

 

Prerequisites 

This course assumes that you have taken, “Introduction to Web Page Creation Using CU People” or have 

equivalent experience.  We will assume you know how to use the Internet, word process, and use an HTML 

editor such as Netscape Composer.  We assume you have designed a basic web page before and know how 

to use FTP software to transfer files from a local machine to a server.  

 

Introduction 
In this two-hour workshop, we will: 

 

• Learn advanced features of Netscape Composer. 

• Learn about GIF and JPEG files 

• Add a JPEG to a page 

• Add an animated GIF image to a page 

• Create navigational buttons  

• Use tables with Composer to lay out text and images 

• Use targets to create internal links 
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• Cut and paste JavaScript into our HTML file to make a rollover effect 

• Install a counter in a web page 

 

The class will provide an introduction to cutting and pasting HTML code, enabling you to add many more 

interesting and creative features to your pages, but this class does not teach HTML programming/coding.  

We only learn the rudiments of HTML, just enough to enable you to paste JavaScript text into your pages.  

At the end of this class we hope to have heightened your awareness of what you can do with your page and 

to have given you the tools to proceed on your own. 

 

We will edit an existing web page such as the one you may have created in “Introduction to Web Page 

Creation”.  The files are located in a folder called Enhance on your local desktop.  They are also available 

to by download from http://www.cit.cornell.edu/training/materials/. 

  

What's a GIF?  What's a JPEG? 
The most popular file formats currently used to display images on the Internet are GIF and JPEG files.  

Graphics Interface Format (GIF) is a compressed standard for images.  GIF images are limited to 256 

colors and are therefore mostly used for cartoon and black and white illustrations.  GIF files also support 

transparencies so that its background color can be the same as the chosen background color for your web 

page.  In addition, GIF supports animation by allowing different still images/frames to be compressed into 

one GIF file. 

 

Joint Photographic Expert Group (JPEG) is another compressed standard. JPEG images can display as 

many as 16 million colors.  It is designed for compressing either full-color or gray-scale digital images of 

"natural", real-world scenes.  If you want to display a scanned picture that has shadows, for example, JPEG 

files will store these features while GIF files will not.  On the other hand, JPEG formatting does not work 

well on non-realistic images such as cartoons or line drawings.  For these purposes, it is best to use a GIF 

format. 
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Add a JPEG to a page 

You already added a GIF to your page in "Introduction to Web Page Creation Using CU People".  Let's add 

a JPEG to a page. 

 

Exercise 

1. Open Netscape Composer. 

2. Go to File > Open Page and open the index.html file on the Enhance folder in the desktop. 

3. Place the cursor underneath the first line of the text in the body. 

4. Click on the Image icon in the toolbar. 

5. Click on Choose File and select the baileyhall.jpg  file from the Enhance folder.  

6. Click OK. 

7. Save  your work. 

8. Preview your page in the browser window by clicking on the Preview button at the top toolbar. 

 

Create 3-D moving text banner (animated GIF) 
There are websites where you can create animated GIF banners using your choice of fonts and animation 

effects.  Let's create a 3-D text banner for our web page header. 

 

Exercise 

1. Open Netscape Navigator and go to http://www.3dtextmaker.com. 

2. Create your 3-D text banner. Complete the 5 steps to customize the banner and press the button 

Make 3D Text! when done. 

3. Right click on the image and choose Save Image As to save the image in your Enhance folder.   

4. Return to Netscape Composer and delete the header in index.html . 

5. Click on the Image icon. 

6. Select the image you just saved by clicking on the Choose File button and searching for the file in 

the Enhance folder.  Click on OK when done. 

7. Save and Preview your page in the browser window by clicking on the Preview button at the top 

toolbar. 

 

Make buttons that are links 

Another way to enhance your web site is to make your images interactive.  For example, you can create 

buttons that help users navigate through your website.  Buttons are simply image files such as GIF or JPEG 

files that are linked to other pages. In this exercise, you will place an image of a button on your page and 

make it a link to another page in the Enhance folder. 
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Exercise 

1. In index.html , highlight the three bulleted lines of text and click on the Bullet List icon on the 

toolbar to remove the bullets. 

2. Place the cursor to the left of the line that reads "discuss my favorite music, movies, and sports 

teams". 

3. Click on the Image icon and select the image file called redball.gif from the Enhance folder. 

Click OK when done. Repeat this step for the next two lines of text. 

4. Highlight the first button by single clicking on it.   

5. Click on the Link  icon in the toolbar.  

6. Under the Link To prompt, select page2.html  from the Enhance folder. 

7. Under the Image tab, make the solid border  0 pixels. 

8. Click OK when done. 

9. Save  your work. 

10. Preview your page in the browser window by clicking on the Preview button at the top toolbar. 

 

Use a table to organize your layout 

Tables are made up of cells stacked into columns and rows, just as in MS Word.  You can place images, 

text, and buttons into the cells to gain more control over alignment.  The following exercise will show you 

how to use tables to help you lay out your web page. 

 

Exercise 

1. Place your cursor on a new line in your Composer window.  

2. Click on Insert  > Table > Table. 

3. Take a minute to look at the different options in table preferences.  

4. Select a 1 x 2 table with borderline, cell spacing, and cell padding equal to 1 pixel. Set the table 

width to 100% of the window. 

5. Click and drag the image, already on your web page, to the second cell. 

6. Highlight the text beginning "Hello..." and continuing through "...post my resume". 

7. Click and drag the selected text to the first cell in the table. 

8. Edit the table by right clicking on any part of the table and choosing Table Properties .  

 

The edit option allows you to change settings for the entire table, or for rows or cells only.  To change a 

setting for a particular row or cell, make sure that your cursor is on that row or cell and that you choose the 

settings from the appropriate tabs on the Table Properties  window. 

 

9. Under the Table tab, make borderline, cell spacing, and cell padding 0 pixels. 

10. Save  your work. 
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11. Preview your page in the browser window by clicking on the Preview button at the top toolbar.  

 

Create links within a page (targets) 
A target is a location within a web page that can be pointed to by a link.  Targets are helpful when you have 

long pages with many discrete sections.  On a long page it may be helpful to link back to the top of the 

page.  Or perhaps you'd like to put an index at the top of your page that links you to other sections of your 

page.  This makes it easier for people to navigate.  Now they can just click on the index link to go directly 

to the target. 

 

Exercise 

1. Place the cursor on a new line after the table you just created and press [Enter] about 20 times.  

2. Now place the cursor at the beginning of the text that reads "Last modified: Jan. 1, 2001". 

3. Click on the Insert menu and choose Target.  

4. Title the target bottom and click OK. A target icon (visible only in the Composer window) 

appears in your document to mark the target's location.  You have just created a target.  The next 

step is to create a link to that target.  

5. Place the cursor on a new line after the table and type Go to bottom of page.  Highlight the text 

when done.  

6. Open the Insert menu and choose Link.  

7. Select the target from the box at the bottom of the properties table.  Click OK when done. 

8. Save  your work. 

9. Check that the target is working by clicking on the Preview button at the top toolbar and testing it 

with the web browser. 

 

Introduction to HTML 
Till now we have been using Netscape Composer to create and modify our web pages.  The files that 

Composer creates are called Hyper Text Markup Language (HTML) files because they contain HTML 

formatting codes.  Web browsers know how to interpret these HTML codes to display HTML files as 

formatted web pages that contain images and links.  It is useful to know some HTML in case you want to 

add features that your editor doesn't support.  For example, if you know a bit about HTML, you can paste 

existing JavaScript code into your HTML to add features like rollovers.  
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Exercise 

1. In Netscape, go to www.cornell.edu. 

2. Select Page Source > View to display the HTML code.  

 

HTML uses tags to instruct the browser how to display a web page.  Tags are bracketed text like this: 

<title>.  Generally tags come in pairs, with an opening and a closing tag to start and end an action.  For 

example : <title> the title would go here </title>.  

 

3. Find the <html>...</html> tags.  These define the beginning and end of a web page.  

4. Find the <head>...</head>  tags.  These provide information about the overall web page.  

5. Find the <body>...</body> tags.  These contain the content that is seen by the users. 

 

Introduction to JavaScript 
JavaScript is a scripting language that enables Web authors to design interactive sites.  The code is written 

within the HTML document. Javascript code interacts with HTML code.   

 

While a JavaScript programmer writes code from scratch, there is a lot of existing JavaScript code available 

on the web that you can use by cutting and pasting it into your document.  When you cut and paste 

JavaScript code into an HTML document you frequently place it between the </title> tag and the </head> 

tag.  Sometimes you place it in the body.  Generally, sites that offer JavaScript code will tell you where to 

place the code.  There are many sites where you can find interesting JavaScript that will enable you to add 

pop up boxes, feedback buttons, mouseovers, and more.   

  

Paste JavaScript into Your Page to Produce Image Rollover Effect  

Let's add an image rollover effect in an HTML document using Composer.  A rollover effect or mouse-over 

uses two images.  One image appears when the user’s mouse is over the graphic and one appears when the 

mouse is not over the graphic.  The two images and the JavaScript code we'll use are in the Enhance 

folder.   
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Exercise 

1. Select Start > Programs > Accessories > Notepad and open index.html from the Enhance 

folder. (Once Notepad is open, you can drag and drop a .txt file onto the Notepad window to open 

it.) 

2. Take a moment to familiarize yourself with the HTML code for this page. 

3. Open rollover.txt  from the Enhance folder using Notepad.   

4. Copy the first block of code and paste it after the </title> and before the </head> tags in the 

index.html file.  

5. Modify the code by replacing On Image goes here with redball.gif. 

6. In the index.html  file, delete the following code: 

 

<a href="page2.html"><img SRC="redball.gif" BORDER=0 height=17 width=17></a> 

 

7. Copy and paste the second block of code in place of the deleted code.  

8. Modify the code you just pasted by replacing Link goes here with page2.html. Replace On 

Image goes here with blueball.gif and Off Image goes here with redball.gif.  Finally, replace 

the Off Image goes here with redball.gif inside the image tag. 

9. Save  the file, return to Composer and click on Preview.  

10. Hover the mouse over the first link of the list to notice the rollover effect. 

 

Add a MIDI file to your page 

Musical Instrument Digital Interface (MIDI) files play music. They are smaller than audio files such as 

.mp3 files and .wav files because they are not digital audio. They are playback instructions to the 

computer’s internal sound synthesizer – much like a digital player piano roll. When you embed a MIDI file, 

you can make it play automatically or allow the user to start and stop playback. Adding sound to your web 

page is similar to adding images. 
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Exercise 

1. Decide which MIDI file you want to play in your web page from http://www.prs.net/midi.html . 

2. Copy the web address of that MIDI file by right clicking the link and choosing the Copy Link 

Location  option. 

3. Add the following code in the index.html  document in the location where you want your music 

console to appear: 

 

<EMBED SRC="http://###" HEIGHT="60" WIDTH="135" AUTOSTART="true"> 

 

4. Replace the source link with the web address where the MIDI file is located by pasting the link 

location inside the source link. Example: 

 

SRC=”http://www.goodtunes.com/song1.mid” 

 

5. Save  the file, return to Composer and click on Preview. 

 

 

 

 

 

Counters and Trackers  

A counter keeps track of the number of visits or "hits" to a web page and generally displays that 

information on the page. Trackers are similar to counters, but do not display the number of hits on the web 

page. Trackers typically also show more information, such the type of browser used and when the page was 

accessed.  

 

Counters and trackers are complicated to program. Fortunately, there are free services that one can sign up 

with, to have others people’s programs and computers keep track of the information that we want. Let's 

sign up for such a service.  

 

WARNING!!! Always make sure that you use material that the copyright holder has explicitly granted you 
permission to use. All materials are copyright protected even if there is no copyrighted symbol associated. 
The web site above lets you use their midi files as long as they play from their site. Downloading the above 
file from their site and playing it from the CU People server would be a violation of copyright. 
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Exercise 

1. Go to http://www.thecounter.com. 

2. Click on the Add Account link in the left sidebar.  

3. Open an account by following the directions on the page. 

4. Then log on to configure your counter. 

5. After log on is completed, click on the Config tab in the navigation bar to the left. 

6. Click on the HTML code link on the navigation bar to the left. 

7. Copy and paste the source code into your index.html file at the location where you want your 

counter to appear. 

8. Save  your file, return to Composer and click on Preview. 

 

Guestbooks 

Guestbooks, which are widely used on personal and commercial web sites allow visitors to enter a 

comment about the web page and have it instantly appear on the web site for others to see.  

 

Once again, the guestbook function is complicated to program from scratch, so we use a free service that 

offer guestbook functionalities. http://guestworld.lycos.com is a website that offers free guestbooks.  This 

works just like registering with a counter/tracker site.  Simply follow the directions to register with them 

and then look for the code to copy and paste onto your web page. 

 

Exploring JavaScript Libraries (Bonus Exercise) 
There are websites that are libraries of  JavaScript code, free to use, for people that would like to make their 

websites interactive but do not want to program from scratch.  In the following exercise, we will go to a 

JavaScript library, customize JavaScript effects using their wizards, and then place the code into our web 

page. 

 

Exercise 

1. In Netscape Navigator, go to http://www.javascriptwizard.com. 

2. Choose a wizard from the left toolbar so that it appears on the right side of the screen. 

3. Follow the directions to customize, copy, and paste the code.  
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Helpful Links 
http://www.cit.cornell.edu/training/materials/students/cupeople/moreinfo.html 

  
Awesome Backgrounds 
 

Background Search - input what you're looking for and the web site does the rest! 
http://imagine.metanet.com/  
 
Enchanted Backgrounds - some of these are really cool!  
http://www.the.enchantress.net/ 
 
Hippie Lady's Free Backgrounds and Other Cool Stuff  
http://members.tripod.com/~HippieLady/ 
 

Clipart, Animated Gifs, Lines, Borders, Bullets, etc. 
The Animation Factory - make sure to check out the "Web Text" at the bottom 
http://www.animationfactory.com/  
 
A-1 Clipart Archive - lines, buttons and bullets galore! 
http://www.free-graphics.com/  

  
Harry's Animated Gif Archive 
http://www.harrythecat.com/graphics/index.htm  

 

Other Awesome Online Resources 
Cool Formats for your web pages. 
http://www.the.enchantress.net 
 
Create animated 3D text that can be done in less than a minute.  
http://www.3dtextmaker.com/  
 
Make any picture into a button!  
http://www.buttonmaker.com/   

 
Optimize and edit those bulky Gif images online! 
http://www.gifworks.com/   

 
Change your web page address into anything you want!!!  

http://move.to/v3home.asp 

Advanced Features... (requires cutting and pasting HTML)  
Mouse Overs - Add color or movement  

 http://library.thinkquest.org/15074/rollover.html   
 
Counter - Free! 
http://www.aaddzz.com/pages/counters   
 
Guest book Free! 
http://guestworld.lycos.com/  
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Add music to your pages, like this  
http://htmlprimer.com/sounds.shtml ...  
 
Daddy Grizzly’s Midi Collection 
http://members.tripod.com/~larrydoz/c_w/c_w.html 

 
JavaScript Tutorials  

Web Monkey's JavaScript Resource Page 
http://www.hotwired.com/webmonkey/programming/javascript/ 

 
Web Site Abstraction's JavaScript Tutorials  
http://wsabstract.com/javaindex.shtml 
 

JavaScript Archives 

Internet.com's Script Collection 
http://javascript.internet.com/toc.html 

DevHead's JavaScript Library 
http://www.zdnet.com/devhead/resources/scriptlibrary/javascript/ 

Tanega: Simple Scripts with Great Explanation 
http://tanega.com/java/java.html 

 

Need More Web Space??? Other free web page services ...  
Fortune City - 100 free megabytes! 
http://www.fortunecity.com/join/index.html  
 
XOOM.com 
http://xoom.com  

 
GeoCities 

http://www.geocities.com  

 

CU People Homepage  

http://www.people.cornell.edu/ 

Download Netscape Communicator for free!  

http://www.netscape.com/download 

Using File Transfer Protocol (FTP)  

CIT QuickTake on FTP: http://www.cit.cornell.edu/atc/materials/QT/ftp.shtml   

Using FTP at Cornell:  http://www.cit.cornell.edu/computer/connect/ftp/ 

 


